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Agenda first session

Creating an MSP plan, the basics 
Working with MSP resource pool 
Uploading files to Epicflow 
Using Your MSP template  
Discussing homework for second training
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Creating an MSP 
plan

the basics

http://wiki-stage.epicflow.com
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You will learn

• Define tasks and relations in MSP 
• Make a detailed plan with milestones, 

resources, work estimations, relations 
• Use the wiki help pages
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The Wiki page

link: wiki-stage.epicflow.com (beta) 
wiki.epicflow.com (final)

https://wiki-stage.epicflow.com
http://wiki.epicflow.com
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Minimum prerequisites
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Order of tasks, 
Role or resource group, 

Rough estimation of work, 
Delivery date

See Wiki: Integration with External Sytems> Planning prerequisites 

https://wiki-stage.epicflow.com/index.php/knowledge-base/minimum-planning-prerequisites/
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Build a house:overview
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• Download training files at wiki: Training and Exercises > 
exercise files 

• Store the files at a shared File location 
See wiki  Integration with MS Project > Shared file location 

• Open “Epicflow Build a house exercise start.mpt” and: 

• Change Task name at line 0 to <Your names>-
house.mpp 

• Save file as <Your names>-house.mpp 
 

• At the start your project looks like this:

Foundation

Ground Floor

Top floor

https://wiki-stage.epicflow.com/index.php/knowledge-base/integration-with-ms-project/#shared-file-location
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Build a house:overview
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Foundation

Ground Floor

Top floor

• Goal is to create a project plan to build a house: 

• Foundation 
• Ground floor 
• Top floor 

• You learn how to add these tasks as details  of 
the Building phase 

• We will use wiki: MS-Project basics > Defining tasks  

• The end result of first exercise looks like this: 
 

https://wiki-stage.epicflow.com/index.php/knowledge-base/ms-project-basics/#defining-tasks


Ⓒ GLOW-management B.V.

Build a house: Add tasks
• Create the 3 task by 

• Inserting 3 tasks below the building phase task 
See Wiki: Defining Tasks>Creating a new task 

• Type task names 
• Indent the 3 new tasks   

wiki: Defining Tasks>Adding the Summary tasks 
 

 9

Foundation

Ground Floor

Top floor

https://wiki-stage.epicflow.com/index.php/knowledge-base/ms-project-basics/#creating-a-new-task
https://wiki-stage.epicflow.com/index.php/knowledge-base/ms-project-basics/#adding-the-summary-tasks
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Build a house: Add relations

• Add relations between tasks 

• Drag relations by hand by clicking on task 
bar 
* The bars have default a length one day, you can make 
them bigger by typing 20 days in the duration column. 
This makes it easier to drag and you can adjust it later. 

• or use predecessor column and type task ID 
• optionally you can also use the successor 

column 
wiki: Defining Tasks>Defining task relations
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Foundation

Ground Floor

Top floor

https://wiki-stage.epicflow.com/index.php/knowledge-base/ms-project-basics/#defining-task-relations
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Build a house: Add Resources

• Check which resources there are available:  
menu View-> Resource sheet 

• Go back to Gantt:  View-> Gantt chart 
wiki: MS-Project Basics >  Gantt, Network and Resource view  
 

• For the new tasks: 
• Select names from dropdown list in “resource 

names column” 
• add to at least one task multiple resources to one 

task: The plumber, mason, carpenter and 
electrician 
wiki: Defining Tasks>Assigning Resources
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Foundation

Ground Floor

Top floor

https://wiki-stage.epicflow.com/index.php/knowledge-base/ms-project-basics/#gantt-network-and-resource-view
https://wiki-stage.epicflow.com/index.php/knowledge-base/ms-project-basics/#assigning-resources
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Build a house: Add Estimations

• Add a rough estimation in the “work” column i.e. 100 hrs 
• Open the split window below: View-> Details  
• Play with the units, work duration, task type in the split window. 

Try to discover the relations. 
• Set the task type back to “Fixed work”.  

wiki: Defining Tasks>Defining work hours

 12Foundation

Ground Floor

Top floor
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Build a house: Save your file
• Forget all the other settings you made in the split window, in 

Epicflow we only look at “Work” and “remaining work”. 
Regardless the mess you made with duration and units 

• If you like you can change the length of the bars and stretch 
them till the delivery date of the 1st of June 2019, the date you 
see in the deadline column. 
Epicflow only looks at the work related to the task. 
 

• Give your project a title (on line 0),  
wiki: Defining Project Settings>project Title 

• Optionally define the name of the project manager  
wiki: Defining Project Settings>Project Manager 

• Save your file (you can use same name as the title)
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Foundation

Ground Floor

Top floor

https://wiki-stage.epicflow.com/index.php/knowledge-base/ms-project-basics/#project-title
https://wiki-stage.epicflow.com/index.php/knowledge-base/ms-project-basics/#project-manager
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Detail the plan  
exercise 2



Ⓒ GLOW-management B.V. wiki-stage.epicflow.com

How much detail?

Sufficient details: If B is required during the execution of A, split A 
into A1 and A2. Meaning: A2 can only start when one A1 and B are 

ready.

A2A1

B

A

B

http://wiki-stage.epicflow.com
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How much detail?

No unnecessary details; unless there is a good reason for it 

Note that a good reason can be to the size of the task. For tracking purposes 
you can decide to break the task up in manageable deliverables. 

A1 A2 AA3

If A1 and A2 have no other successors and A2 and A3 have no 
other predecessors, these tasks can be replaced by a single 
task if they are executed by the same resource.

http://wiki-stage.epicflow.com
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Detail the plan 
exercise 2

 General sequence: 
1. Add detailed tasks 
2. Add relations 
3. Add resources 
4. Add work estimation 

- The budget specification can be found in excel sheet 
“Budget & tasks my house.xlsx” (see downloaded files) 

- add new tasks per phase and copy them in  

- remove the resources from the summary task to 
prevent double count. 

- wiki: MS-Project basics > Defining Tasks

Total	budget 1.800	hrs

Preparation 320	hrs

Engineering-construction Engineering 160	hrs

Engineering-electric Engineering 160	hrs
Building	phase 1.480	hrs
Foundation 560	hrs

Create	formwork	for	concrete Carpenter 80	hrs
Pooring	Concrete Mason 40	hrs
Remove	formwork Mason 40	hrs

Placing	of	floor	elements Carpenter 40	hrs

Construction	of	sewerage Plumber 120	hrs

Construction	waterpipe Plumber 80	hrs

Construction	of	main	power,	
glass-fiber

Electrician 160	hrs

Ground	floor 440	hrs
Placing	of	wall	elements	and	
ceiling

Carpenter 40	hrs

Brick	walls Mason 160	hrs
Place	window	and	door	frames Carpenter 40	hrs
Create	kitchen Carpenter 80	hrs
Place	bathroom Plumber 40	hrs

Create	electricity	network Electrician 40	hrs
Painting Painter 40	hrs
Topfloor 400	hrs

Placing	of	wall	elements Carpenter 40	hrs
Brick	walls Mason 160	hrs
Place	window	and	door	frames Carpenter 40	hrs
Place	bathroom Plumber 40	hrs

Create	electricity	network Electrician 40	hrs
Painting Painter 40	hrs
Build	roof Carpenter 40	hrs
Finishing
Rework	and	handover	to	owners Carpenter 80	hrs

https://wiki-stage.epicflow.com/index.php/knowledge-base/ms-project-basics/#defining-tasks
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Task times

Why is it so difficult to answer how long it takes 
to accomplish a task? 

Is it important to know when every task starts 
and ends? 
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Task times & execution losses

Work Content Interruptions Parkinson’s  
law

time takentime takentime taken

?
• Resources are temporary not available 
• Rework 
• Delays in approvals and resolving issues 
• Information missing 
• Materials not available 
• Meetings 
• Material delays 
• Paperwork delays 
• High prio unplanned projects 
• Change in project priorities, causing trashing 
• Mis-communication between departments 
• ….
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Total time taken

• Sense of urgency more towards 
the milestone 

• Most completions of work items 
reported on or after estimated time 

• Gold plating / polishing 
• Wait till longest task is finished  
• Too long tasks 
• Student syndrome 
• ……

• Resources are temporary not available 
• Rework 
• Delays in approvals / Reviews 
• Information missing 
• Materials not available 
• Meetings 
• Material delays 
• Paperwork delays 
• High prio unplanned projects 
• Change in project priorities, causing trashing 
• Mis-communication between departments 
• ….

Task times & execution losses

Work Content Interruptions Parkinson’s  
law

http://wiki-stage.epicflow.com
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Is it important to know when 
every task starts and ends? 
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A Route Planning
Locatie Afstand Aanwijzing Tellerstand Tijd 
Bornsestraat 140 m rechtsaf, verder per auto de op-/afrit op 140 m 00:04:08 
(A1) 3,5 km wegnummer wijzigt in A35 3,6 km 00:06:03 
(A35) 2,6 km neem de afslag naar de A1 (E30) richting Deventer, Amsterdam 6,3 km 00:07:16 
(A1) 23 Deventer 37,6 km  43,8 km 00:24:51 
(A1) 9,8 km wegnummer wijzigt in A50 53,6 km 00:29:21 
(A50) 40 m wegnummer wijzigt in A1 53,7 km 00:29:23 
(A1) 21 Bussloo 1,4 km  55,1 km 00:30:01 
(A1) 3,4 km wegnummer wijzigt in A50 58,4 km 00:31:34 
(A50) 40 m wegnummer wijzigt in A1 58,5 km 00:31:35 
(A1) 20 Apeldoorn-Zuid 1,0 km  59,5 km 00:32:03 
(A1) 1,2 km wegnummer wijzigt in A50 60,7 km 00:32:37 
(A50) 20 m wegnummer wijzigt in A1 60,7 km 00:32:37 
(A1) 11 Eembrugge 49,1 km  110 km 00:55:12 
(A1) 1,8 km volg de A1 richting Hilversum-Noord, Amsterdam 112 km 00:56:02 
(A1) 3 Muiden 20,9 km  133 km 01:05:39 
(A1) 3,0 km neem de afslag naar de A9 richting A'Dam-Zuidoost, Haarlem, Schiphol 136 km 01:07:01 
(A9) 2 Bijlmermeer 5,0 km  141 km 01:09:26 
(A9) 1,9 km neem de afslag naar de A2 (E35) richting Amsterdam, Zaanstad 142 km 01:10:19 
(A2) 1,4 km neem afslag 2 naar de S111, richting Ouderkerk Ad Amstel, Duivendrecht 144 km 01:11:08 
 380 m linksaf richting Burgemeester Stramanweg 144 km 01:11:49 
Burgemeester Stramanweg 100 m ga de op-/afrit op naar de S111 144 km 01:12:03 
 110 m linksaf 145 km 01:13:19 
 390 m linksaf naar de S111 145 km 01:17:14 
(S111) Holterbergweg 890 m  146 km 01:20:14

http://wiki-stage.epicflow.com
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A Route Planning 
146 km, 1h20min, ETA 11.00 AM, no traffic jam 
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Task times
Which times we want to know? 

• When project starts and ends. 

• Some crucial delivery dates in the project.  

For those moments we add milestones

When are task durations important? 

• For durations that are hard to influence. i.e drying time, 
order lead-time, processing time external parties,  in general: 
waiting times 

For those tasks we add Un-Compressible Lead Time (UCLT) 

Natural law: every milestone will cost extra effort from the 
team to meet and management to manage.
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Task times
Add the following milestones: 

• Preparation ready  
• Foundation ready 
• Roof ready 

wiki: MS-Project basics > Defining Tasks > Creating Milestones 

Add the following UCLT tasks wiki: “UCLT” 
• Ordering goods (4 weeks, prep phase) 
• Waiting for building permits (8 weeks) 
• Drying time of concrete (4 weeks) 

wiki: MS-Project basics > Defining Tasks > Creating UCLT Task

https://wiki-stage.epicflow.com/index.php/knowledge-base/ms-project-basics/#creating-milestones
https://wiki-stage.epicflow.com/index.php/knowledge-base/ms-project-basics/#creating-uclt-task
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Network view
Instead of the Gantt view you can also look at the Network view to see how tasks 
are related. 

You can view this network by: wiki: “Network MSP”  

• Select View-> Network Diagram  (Epicflow Network) 
• Right click outside the blocks and select “Lay-out now” 
•Check the lay-out, look for summary task and expand and collapse them to see 
what happens 

• Double click on relations, check options and delete 
a relation 

• Create the relation again by click-hold-drag from 
one task to the other 

 
What happens to the network if the duration 
changes in the Gantt? 

What happens to the network if the task is 
rescheduled?  
 
wiki:  Gantt, Network and Resource view > Network 
Diagram

https://wiki-stage.epicflow.com/index.php/knowledge-base/ms-project-basics/#network-diagram
https://wiki-stage.epicflow.com/index.php/knowledge-base/ms-project-basics/#network-diagram
https://wiki-stage.epicflow.com/index.php/knowledge-base/ms-project-basics/#network-diagram
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Working with MSP 
resource pool

http://wiki-stage.epicflow.com
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Share resource pool
Open resource sheet of your project file again. Here you see only the 
resource related to this project.  

Open “Epicflow Resource pool Training v1.mpp” (does not matter if it is in 
read only or read-write mode) 

Switch to your project file. View->Switch window 

Go to Resources->Resource pool->Share Resources 

Select Use Resources From “Epicflow Resource pool Training v1.mpp”  
wiki: Defining the resource pool>Connect to Resource Pool

https://wiki-stage.epicflow.com/index.php/knowledge-base/ms-project-basics/#connect-a-project-to-resource-pool
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The resource pool
In the Resource Sheet of your project File 
you now see the all resources from the 
resource pool. 

Every Resource group has now resources in 
its group. 

MSP does not support assignment to 
resource groups. Thats why we create a 
special resource for that.

Columns: 

R &G (Epicflow custom field): 
R=Resource, G=Group 

Parent (Epicflow custom field):  
Tells a resource to which group it belongs 

Group: MSP field, also visible in task list 
as “Resource Group” 

Unique ID: MSP field that identifies 
resource, strange thing that it changes 
when you close the resource pool. 
wiki: Gantt, Network and Resource view > 
Resource Sheet
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MS-project Config

 30

Show project summary task on line 0 Switch off schedule update settings

Change default file save location Set default task type to fixed work
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Create FLOW
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Not overhead!


